21 Apr 2021 
Centre d'assistance » Base de connaissances » Mise à jour vers une nouvelle version
 Connexion [Mot de passe perdu] 
Courriel:
Mot de passe:
Se souvenir de moi:
 
 Recherche
 Détails des articles
 Mise à jour vers une nouvelle version
Solution IceWarp v11, v12, v13 -

La mise à jour de la version sur le serveur nécessite toujours une bonne attention.
Voici les précautions générales et quelques indications particulières.

* Passage à la version 13.0 (Deep Castle 2)

Deux points importants :

- La fonction (ou microservice) WebDocuments en version sur site est abandonnée au profit d'une version Cloud

- La fonction (ou microservice) WebMeeting en version sur site est abandonnée au profit d'une version Cloud

Au cours d'une mise à jour, il vous sera donc proposé de choisir soit la version Cloud, soit de rester avec la version sur site qui ne sera plus mise à jour. Si vous choisissez la version Cloud, il vous sera demandé de prendre un abonnement.
Il faut pour cela impérativement aller sur la page Web mentionnée dans le Pop-up, prendre connaissance des changements qui rentrent en vigueur avec la V13, accepter les conditions sur la dernière page et valider tout.

Par ailleurs, il est maintenant nécessaire de renouveler la maintenance à la fin de la période en cours - sinon, tous les services pourront s'arrêter de fonctionner après une période de grâce de 30 jours.

Dans cette version, la sécurité est renforcée et les mots de passe sont cryptés par défaut. Il n'est plus possible pour l'administrateur de les lire, en cas d'oubli, il faut les remplacer.

Voir plus de détails sur les évolutions de configuration dans cette note


* Passage à la version 12.3 (Deep Castle 1)

Si vous passez d'une version 12.2 ou antérieure à 12.3, vérifiez les points suivants :
- Cette version ne fonctionne qu'à partir de Windows 2008 R2
- PHP : la version de PHP pour la 12.3 est 7.3.11
- La structure du php.ini est différente. Pour les extensions, il ne faut pas écrire :
extension=php_mysqli.dll
mais
extension=mysqli
Donc, modifier php.user.ini (s'il existe)
- Si vous utilisez des modules comme soap, curl, il faut prendre les librairies libssh2.dll et nghttp2.dll  ainsi que les extensions manquantes dans https://windows.php.net/downloads/releases/archives/php-7.3.11-Win32-VC15-x86.zip et les placer dans le dossier php.
Pour le module curl, il faut ajouter le répertoire d'installation IceWarp dans PATH Windows.
- La version intègre un système de recherche plein texte dans le dossier mail, consultez la FAQ sur ce sujet pour plus de détails.

* Les anciennes versions

- Les versions anciennes du plugin IceWarp Outlook Sync (version 10 et suivantes) ainsi que du Desktop Client (version 5 et suivantes) fonctionnent avec les nouvelles versions du serveur IceWarp. Il est toutefois conseillé de planifier progressivement la mise à jour des clients.
- L'interface v10 du Client Web est encore disponible en v11 mais n'est plus disponible en v12. Tous les utilisateurs devront utiliser la nouvelle interface en v12.

- A partir de la v12.0, l'analyseur de journaux n'est plus disponible

- A partir de la v12.0 un nouveau protocole est utilisé par le Client Web (WebSocket) ce qui peut poser des problèmes s'il y a un proxy, vérifier qu'il ne bloque pas ce protocole.

- Si la version de départ est antérieure à 11.4 il est conseillé de faire d'abord une mise à jour vers 11.4 puis la mise à jour vers v12.


* Précautions à l'installation

Avant l'installation
- Vérifiez que le journal "Maintenance" est activé en mode étendu sur le serveur
- Vérifiez que votre licence est à jour
- Notez le numéro de version (dans le titre la console d'administration)
- Sauvegardez la configuration dans un fichier .zip (Fichier -> Sauvegarder la configuration)
- Si vous utilisez des bases de données autre que SQLite, les sauvegarder par un outil externe
- Notez les modifications personnalisées qui auraient été effectuées directement dans des fichiers du serveur
- Téléchargez le binaire de la dernière version disponible sur le site www.icewarp.fr
- Serveurs en cluster : tous les serveurs doivent être modifiés en même temps
- Vérifiez que les bases de données en MySQL ou MSSQL utilisent bien le moteur innoDB et que le jeu de caractère est utf8. Les bases à vérifier sont : Comptes, GroupWare, Anti-Spam, Cache répertoire, Cache Client Web, Cache ActiveSync, Cache rapports de spam. Pour corriger le problème le cas échéant, il faut recréer de nouvelles bases et faire la migration des bases (Outils -> Migration bases de données) avant de basculer de version.

Installation
- Fermer la console d'administration
- Effacer le contenu du dossier php\temp situé dans le dossier principal d'IceWarp. Ceci ferme tous les utilisateurs du Client Web et les oblige à se reconnecter après redémarrage des services.
- Exécutez le setup d'installation en tant qu'administrateur système
Les services sont interrompus pour une durée de quelques minutes maximum généralement
La mise à jour des bases de données peut cependant être relativement longue si elles sont volumineuses.

Après l'installation
- Vérifiez l'absence d'erreur dans le journal "maintenance"
- Refaites les modifications personnalisées le cas échéant
- Vérifications:
** Dans Système -> Services, vérifiez que les services dont vous avez besoin sont en vert et les autres en rouge
** Regardez le journal "maintenance". Si vous voyez une erreur concernant la procédure de mise à jour alors, ouvrir une fenêtre MS-DOS, allez dans le répertoire d'installation d'IceWarp et exécutez
tool upgrade <numéro de version juste avant la mise à jour>
(en cas de doute nous envoyer le journal de maintenance)
** Vérifiez le fonctionnement global
Après passage en v12, des actions d'optimisation du système peuvent être effectuées si besoin
Demander aux utilisateurs du Client Web de fermer puis ré-ouvrir leur session, dans certains cas il faudra réinitialiser le cache du navigateur.
Regardez sur le site dans l’onglet Support -> Administrateur s'il n'y a pas un patch à appliquer à la version installée

Si vous utilisez la librairie libtcmalloc_minimal_64.dll (elle doit alors être dans le dossier d'installation d'IceWarp) il faut s'assurer qu'il s'agit de la bonne version.
Il faut alors recopier cette librairie de .../lib/win64/libtcmalloc_minimal_64.dll vers le dossier d'installation et redémarrer tous les services.

 

Si vous utilisez un antivirus externe sur le serveur IceWarp, il faut prendre les précautions suivantes :
- exclure du scan de l'antivirus externe
 ** le répertoire d'installation d'IceWarp
 ** le répertoire .../mail/_incoming
 ** le répertoire .../mail/_outgoing
 ** le répertoire .../temp
- si l'antivirus externe possède un composant POP/IMAP/SMTP, ne pas l'activer (il faut que les binaires IceWarp soient les seuls à implémenter les fonctions POP/IMAP/SMTP)
- si l'antivirus externe scan les ports 110/995/143/993/25/465/366/587, il faut désactiver ces scans.

 

Modifié le 20 avril 2021


Détails des articles
Code d'identification de l'article: 372
Créé le: 20 Feb 2014 06:16 PM

 Cette réponse m'a été utile  Cette réponse ne m'a pas été utile